Mostrando las entradas con la etiqueta Telemática y Redes. Mostrar todas las entradas
Mostrando las entradas con la etiqueta Telemática y Redes. Mostrar todas las entradas

Enrutamiento de VLAN's

Para realizar el enrutamiento de VLAN’s se deben crear sub-interfaces en el enlace troncal que comunica el Switch y el Router, estás sub-interfaces se crean mediante un proceso de encapsulamiento de las VLAN.

Enrutamiento de VLAN usando un Router:

En el ejemplo siguiente se crearán tres VLAN
VLAN 10: 192.168.10.0/24
VLAN 20: 192.168.20.0/24
VLAN 30: 192.168.30.0/24


  • Se asignan las direcciones IP a los equipos que conforman las VLAN
Equipos de la VLAN 10:
Equipo Dirección IP Mascara Puerta de Enlace
Laptop 0 192.168.10.2 255.255.255.0 192.168.10.1

Equipos de la VLAN 20:
Equipo Dirección IP Mascara Puerta de Enlace
Laptop 1 192.168.20.2 255.255.255.0 192.168.20.1
Laptop 2 192.168.20.3 255.255.255.0 192.168.20.1

Equipos de la VLAN 30:
Equipo Dirección IP Mascara Puerta de Enlace
Laptop 3 192.168.30.2 255.255.255.0 192.168.30.1
Laptop 4 192.168.30.3 255.255.255.0 192.168.30.1
Laptop 5 192.168.30.4 255.255.255.0 192.168.30.1

  • Se crean las VLAN en el Switch
Switch>
Switch>enable
Switch# configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit

  • Se asignan cada VLAN en los puertos del Switch que se van a utilizar, en este caso de los puertos del 2 al 7
Switch(config)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fa0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#interface fa0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#interface fa0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit

  • Se crea el enlace troncal que comunica al Switch y el Router
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk

  • Se configuran las VLAN en el Router
Router>enable
Router #configure terminal
Router (config)#hostname R1
R1(config)#interface fa0/0
R1(config-if)#no shutdown
R1(config-if)#interface fa0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#exit

  • Se guarda la configuración del Router y del Switch
R1# copy running-config startup-config
Switch# copy running-config startup-config

Enrutamiento de VLAN usando un Switch capa 3:

En el ejemplo siguiente se crearán tres VLAN
VLAN 10: 192.168.10.0/24
VLAN 20: 192.168.20.0/24
VLAN 30: 192.168.30.0/24


  • Se asignan las direcciones IP a los equipos que conforman las VLAN
Equipos de la VLAN 10:
Equipo Dirección IP Mascara Puerta de Enlace
PC 0 192.168.10.2 255.255.255.0 192.168.10.1
PC 1 192.168.10.3 255.255.255.0 192.168.10.1

Equipos de la VLAN 20:
Equipo Dirección IP Mascara Puerta de Enlace
PC 2 192.168.20.2 255.255.255.0 192.168.20.1
PC 3 192.168.20.3 255.255.255.0 192.168.20.1
PC 4 192.168.20.4 255.255.255.0 192.168.20.1

Equipos de la VLAN 30:
Equipo Dirección IP Mascara Puerta de Enlace
PC 5 192.168.30.2 255.255.255.0 192.168.30.1

  • Se crean las VLAN en el Switch capa 2
Switch>
Switch>enable
Switch# configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit

  • Se asignan cada VLAN en los puertos del Switch que se van a utilizar, en este caso de los puertos del 2 al 7
Switch(config)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fa0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fa0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fa0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit

  • Se crea el enlace troncal que comunica al Switch capa 2 y el Switch capa 3
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk

  • Se crean las VLAN en el Switch capa 3
Switch >enable
Switch #configure terminal
Switch (config)# hostname SwitchCapa3
SwitchCapa3 (config)#vlan 10
SwitchCapa3 (config-vlan)#exit
SwitchCapa3 (config)#vlan 20
SwitchCapa3 (config-vlan)#exit
SwitchCapa3 (config)#vlan 30
SwitchCapa3 (config-vlan)#exit

  • Se configuran las VLAN en el Switch capa 3
SwitchCapa3(config)#interface vlan 10
SwitchCapa3(config-if)#ip address 192.168.10.1 255.255.255.0
SwitchCapa3(config-if)#exit
SwitchCapa3(config)#interface vlan 20
SwitchCapa3(config-if)#ip address 192.168.20.1 255.255.255.0
SwitchCapa3(config-if)#exit
SwitchCapa3(config)#interface vlan 30
SwitchCapa3(config-if)#ip address 192.168.30.1 255.255.255.0
SwitchCapa3(config-if)#exit
SwitchCapa3(config)#ip routing

  • Se guarda la configuración del Switch capa 3 y del Switch capa 2
SwitchCapa3# copy running-config startup-config
Switch# copy running-config startup-config

Modelo OSI, Modelo TCP/IP Y Estándares IEEE 802

El Modelo OSI (Open System Interconnection) es resultado de una serie de investigaciones de la ISO (International Organization for Standardization), en el que se identificaron las necesidades para la creación de un modelo de red que facilitara la interoperabilidad entre redes, el resultado final fue publicado en el año 1984.
El Modelo OSI realiza un análisis de la red en siete capas, distribuidas de la siguiente forma:

Capa 7: Aplicación
Capa 6: Presentación
Capa 5: Sesión
Capa 4: Transporte
Capa 3: Red
Capa 2: Enlace de datos
Capa 1: Física

Esta visión por capas ofrece una serie de ventajas, entre ellas, la visión modular de las redes, estandariza interfaces, reduce la complejidad porque divide un problema grande en problemas más pequeños y facilita la enseñanza - aprendizaje.

Cada una de las capas del Modelo OSI tiene funciones definidas para que el paquete de datos llegue de su origen al destino, brevemente las funciones de cada capaz son las siguientes:

Capa 7: Aplicación, esta capa es la más cercana al usuario, es la responsable de ofrecer servicios de red a las aplicaciones que los usuarios utilizan, como por ejemplo el correo electrónico, bases de datos, etc.
Capa 6: Presentación, esta capa se encarga del formato para que la capa de aplicación pueda interpretar los datos enviados por la red.
Capa 5: Sesión, se encarga de establecer, iniciar y finalizar la sesión entre dos host que se están comunicando.
Capa 4: Transporte, se encarga del transporte de datos del emisor al receptor y la comprobación de errores en el transporte.
Capa 3: Red, en esta capa se determina la forma en que los datos serán mandados al receptor manejando los protocolos de enrutamiento y de direcciones IP
Capa 2: Enlace de datos, su función es proporcionar un tránsito confiable de datos a través de un enlace mediante direccionamiento físico y de la entrega ordenada de tramas y el control de flujo.
Capa 1: Física, se definen especificaciones eléctricas, eléctricas, mecánicas, de procedimiento y funcionales para activar, mantener y desactivar el enlace físico entre sistemas finales.


El Modelo TCP/IP fue desarrollado y demostrado por primera vez en 1972 por el departamento de defensa de los Estados Unidos, también está formado por capas, sino que en este caso el número de capas es menor, solo 4.

En el Modelo TCP/IP las dos capas inferiores (Capa 1 y Capa 2) se unen en una capa denominada Capa 1: Capa de acceso a la red, la segunda capa guarda concordancia con la capa de red, pero cambia de nombre, en este caso se denomina Capa 2: Internet, la tercera capa del modelo TCP/IP es la capa de transporte, la Capa 5, 6 y 7 del Modelo OSI son asimilables como Capa 4: Aplicación.

El modelo TCP/IP tiene menor número de capaz por lo que a vez son más complejas las funciones de cada una de ellas.

Los Estándares IEEE 802 están definido por comités del Instituto de Ingeniería Eléctrica y Electrónica, son los estándares LAN más conocidos en la actualidad, su función principal es brindar estándares para que la tecnología de diferentes fabricantes se pueda integrar entre sí, es decir, asegurar mayor compatibilidad entre tecnologías.

IEEE 802 dividen la Capa 2 del Modelo OSI, es decir, la capa de enlace de datos, en dos subniveles, la de Control de Enlace Lógico (LLC) y la de Control de Acceso al Medio (MAC)

El subnivel de Control de Enlace Lógico establece y finaliza los enlaces, contrala el tráfico de tramas, las secuencia y confirma su recepción, definidos en el Estándar 802.2.

El subnivel de Control de Acceso al Medio se encarga de gestionar el acceso al medio, delimita las tramas, comprueba sus errores y reconoce sus direcciones. Los Estándares 802.3, 802.4, 802.5 y 802.12 definen estándares para el subnivel MAC y para la Capa 1: Física del Modelo OSI

A continuación se muestra una tabla resumen que compara los Modelos OSI y TCP/IP y a los Estándares 802

Estándar IEEE 802 Modelo OSI PDU Modelo TCP/IP
Capa 7: Aplicación Datos Aplicación
Capa 6: Presentación Datos
Capa 5: Sesión Datos
Capa 4: Transporte Segmentos Transporte
Capa 3: Red Paquetes Internet
Control Lógico de Enlace (LLC) → 802.2 Capa 2: Enlace de datos Tramas Acceso a la Red
Control de Acceso al Medio (MAC) → 802.3, 802.4, 802.5 y 802.12
Capa 1: Física Bits

REFERENCIAS BIBLIOGRÁFICAS